quarta-feira, 3 de março de 2010

Atualizando Motorola Milestone Brasileiro para Android 2.0.1

Disclaimer: Todo o procedimento aqui descrito foi concedido gentilmente pelo Rodrigo Haydt.

Disclaimer2: É com muita dor no coração que digo que neste tutorial usaremos Windows e ferramentas proprietárias de código fechado da Motorola. O que particularmente é um absurdo. Pra que diabos a gente precisa de ferramentas proprietárias e que rodem no Windows pra flashar um device que roda Linux? Mas enfim, dancemos conforme a música :-(

Disclaimer3: Faça todo este procedimento por sua conta em risco. Fazer de forma errada o procedimento pode brickar seu telefone e transforma-lo em um elegantíssimo peso de papel. Tenha certeza que seu celular esteja carregado em 100% e que não haverá falhas ou interrupção de energia elétrica - recomendo fazer de um notebook para evitar este último.
1) A receita de bolo é bastante simples, pegue os ingredientes:
Motorola Driver Installation 4.2.0 - Windows (32bit / 64bits)
RSD Lite 4.6 [update: o arquivo não está mais neste servidor, não achei na busca que fiz. Se alguém achar poste ai nos comentários]
2) Pegue a imagem inglesa do Android 2.0.1 que instalaremos no celular e descompacte. [update: imagem brasileira do android 2.0.1 já disponível] [update2: imagem européia do android 2.1 já disponível]

3) Em seu Milestone, vá em Settings > Applications > Development e ative o USB Debugging.

4) Conecte seu telefone ao computador pela porta USB utilizando o cabo de dados.

5) Espere até o Windows achar seu device, instalar os drivers e tal e coisa. Tudo isso feito, abra o RSD Lite e espere até que o device A853 apareça na tabela.

6) Selecione o arquivo de imagem que você descompactou na caixa de texto e clique em Start.

7) Agora é a hora que a mágica do software proprietário acontece. Todo o processo vai demorar uns 10min e o telefone irá rebootar umas 3 vezes. O RSD Lite eventualmente pedirá pra ligar o celular e como você leu este tutorial você NÃO FARÁ ISSO. Seja paciente e espere até que esteja escrito Finished e PASS na tabela do RSD Lite.

Pronto, agora você tem o Android 2.0.1 no seu Motorola Milestone GSM Brasileiro. E aí, o que eu ganho com isso? Agora você vai poder instalar o Google Earth (que é mais cool do que útil por enquanto), vai poder instalar um novo aplicativo pro Dock (que é menos brilhante e você poderá dormir com mais facilidade) e vai poder instalar um novo Home (que é o nativo do Nexus 1, é cool também, mas ainda ta cheio de bug). Agora sério, a atualização deixou o Android mais rápido e aquelas travadas (e até reboots) esporádicos sumiram. A tela me pareceu mais responsiva e o consumo de bateria diminuiu sensivelmente.

Downgrade: Caso você não tenha gostado, ou tenha bugado seu telefone por algum motivo, você pode fazer o downgrade usando o mesmo procedimento mas com a imagem do Android 2.0.

Importante: O upgrade conserva todas as configurações do seu aparelho, o que não é verdade no caso do downgrade. Seu celular vai estar como se estivesse tirado da caixa.

49 comentários:

Michel disse...

sinto informar que quem fizer isso perde a banda 3G 850mhz

Without Notice disse...

ao conectar na USB fazer o seguinte passo: Boot up in bootloader (hold power + volume up + camera)

@drobnicki

carlose disse...

E ai.... rs
Alguem ja tentou?

Santoja disse...

Cara, testei aqui e deu tudo certo, só concerta o link da imagem do milestone, o link daqui esta o da versão UK, eu entrei no site e baixei a versão BR (aqui tem os drivers que vc perdeu http://and-developers.com/motorola_milestone:tools:usb_drivers

Valeu mesmo =)

Droid Brasil disse...

Esta imagem do 2.0.1 é em português?

Droid Brasil disse...

RSDLite: http://www.mediafire.com/?c2tibonomyn

biggahed disse...

Brigadao cara, acho que funcionou aqui
Vou testar e ver se ficou legal, mas instalar pelo menos instalou :)

[]s

impacto disse...

Olá,

Fiquei muito entusiasmado com esse seu post. Mas surgiram algumas dúvidas e queria saber se você tem as respostas.

1) Esse procedimento faz com que eu perca a garantia de meu aparelho comprado pela Vivo?

2) Tenho softwares pagos instalados no meu aparelho. O que acontece com esses softwares após a instalação?

3) Há a possibilidade de sair atualização no futuro para o Android 2.1. Quando (ou se) essa atualização sair, poderei atualizar, de forma oficial, o meu aparelho?

Sabe alguma coisa sobre isso?

Até mais.

rbow disse...

Fala Eduardo.
Fiz o procedimento como você bem descreveu no seu tutorial e funcionou perfeitamente!
A única diferença é que baixei a versão 4.5.7 do RSD Lite porque, por algum motivo, a versão 4.5.3 estava dando pau.
Muito obrigado pela dica!


Ronald Bulbow
Motorola Milestone 2.0.1 rooted

Thiago disse...

Obrigadão, funcionou tudo certo. Só um parênteses, não achei a versão 4.6 do RSD Lite, fiz com a 4.5.7 msm, deu tudo okay;

Edgar Menezes disse...

Valeu cara!
Tava procurando um tutorial de como fazer isso no aparelho!
Abraços!

Krys disse...

link funcional do RSDLite 4.6:

http://www.mediafire.com/?c2tibonomyn

Ronald Bulbow disse...

Fala Eduardo.
Mais um post só pra avisar que fiz o procedimento no Milestone de um outro amigo e também funcionou de boa.
A única diferença é que usei o RSD Lite 4.5.7 e fiz o processo num Windows 7 Entreprise (processo um pouco diferente):

- Copie o arquivo *.sbf para o diretório do RSD Lite (C:\Program Files (x86)\Motorola\RSD Lite);
- Coloque o Milestone em 'bootloader mode' e conecte ao PC;
- Abra o prompt do DOS e vá para o diretório do RSD Lite (C:\>cd "Program Files (x86)\Motorola\RSD Lite");
- Execute a seguinte linha de comando:
C:\Program Files (x86)\Motorola\RSD Lite>sdl.exe -f .sbf -t 2

Referência: http://www.mmus.us/forum/showthread.php?t=8101

[]'s

Ronald

Anônimo disse...

ótimo post!
tudo perfeito aqui!
obrigado

DDM disse...

Caro,

fiz os downloads necessários e coloquei o celular no modo correto, porém o rsdlite nao reconhece meu milestone. Já resintalei o driver da motorola mas nada acontece.

Alguma luz?

Diogo

Cassiano disse...

Amigo, trabalhei na motorola um tempo, bom tempo, e vendo seu tutorial fiquei curioso, pq não faze-lo por FOTA (Firmware over the Air).
Consegui faze-lo sem usar estes procedimentos que você enviou porem precisei usar meu usuario e senha da motorola no servidor de fota deles (não existe server gratuito disto) e funcionou que é uma beleza.
Obrigado pela dica,
Cassiano

Qto ao RSD pode ser encontrado facilmente em sites gringos, go Google :)

ERICK THIAGO disse...

tenho um milestone estava atualizado para 2.0.1,seguindo o tutorial acima atualizei para 2.1
europeu ficou show,vem em portugues
portugal.parabens pelo tutorial.

Daniel disse...

se eu instalar a imagem brasileira do Update 1, ainda perco 3G 850 MHz?? Não faz sentido tirar 850MHz em um firmware para o Brasil! Estou no RS e uso Claro, não estou conseguindo conectar 3G, por isso pergunto

Eduardo Otubo disse...

@Daniel,

Não o vai perder não. O Android 2.0.1 tem todas as bandas operantes :-)

[]'s

Daniel disse...

Amigo, obrigado pela resposta.
Então o primeiro comentário, do Michel, não procede? ou se refere ao firmware inglês?

Eduardo Otubo disse...

@Daniel,

O Comentário do Michael é relativo à primeira versão do post que falava da atualização para Android 2.0.1 inglesa. Eu sei, o post ficou uma zona com vários updates no meio, preciso parar com essa mania e escrever posts separados :-)

[]'s

Daniel disse...

sem querer abusar da boa vontade, mas correndo o risco de já o estar fazendo:

não consigo utilizar 3G da claro..
será que é um problema só de configuração do APN? sabe a configuração aqui pro RS?
outra coisa, disquei *#*#INFO#*#* e mudei a rede para WCDMA preferred, fiz bem?

muito obrigado!

Eduardo Otubo disse...

@Daniel, você já tentou configurar as APNs de acordo com o link lá no post?

Daniel disse...

olá,

não encontrei nenhum link que mencione APNs, muito menos da Claro. Poderia me linkar?

Eduardo Otubo disse...

@Daniel, putz, verdade, não postei o link de como configurar as APNs. Neste link do forum tem como configurar apenas as APNs para Vivo, não procurei em outros posts se tem pra Claro ou não - mas se não tiver até rola perguntar, eles são muito solícitos para ajudar.

Qualquer novidade de como configurar APNs Claro comenta aqui que eue atualizo o post.

Valeu!
[]'s

Eduardo Otubo disse...

E aqui está o link pro forum. Boa sorte!

Daniel disse...

Consegui configurar o APN!

mas encontrei um novo problema: parece que apenas o browser padrão consegue "acordar" o 3g, os demais programas ficam inertes, nem tentam conectar, já teve este problema??
não sei mais o que fazer..

ERICK THIAGO disse...

Atualizei meu milestone seguindo este tutorial más as vezes quando
faço uma ligação ele simplismente apaga,más não desliga tenho que esperar alguns instantes para ele voltar ao normal.tem alguma solução a respeito.

Eduardo Otubo disse...

@Daniel, já tentou o APDroid?

@ERICK, nunca passei por isso, não faço nem idéia.

[]'s

ERICK THIAGO disse...

Descobrir que o problema do aparelho, só a contece quando estou na rua dentro de casa funciona perfeito vá entender.

Anônimo disse...

Fiz, todo o tutorial, porem o milestone continuou bloqueado para a operadora OI.
Alguem pode ajudar?

srgcruz disse...

Prezados!
Segui todo o tutorial, porem o aparelho atualizou a versão porem continuou bloqueado.
Alguem pode ajudar!

Eduardo Otubo disse...

Senhores,

O procedimento não desbloqueia para usar operadoras diferentes! :-)

[]'s

Zamana disse...

Esta versão 2.1 Européia não tem suporte para a rede 850MHz utilizada por algumas operadoras (Vivo).

Já a versão "Thai" (Tailandesa) tem suporte para todas as 4 frequências utilizadas no Brasil: 850/1800/1900/2100.

Tutorial completo:
http://www.hurbanoide.com/blog/2010/04/instalando-firmware-2-1-no-motorola-milestone/

Não é diferente do esquema que está explicado aqui, mas tem os links para os arquivos todos (e nada de MegaUpload, RapidShare e essa porcaria toda).

Eduardo Otubo disse...

@Zamana,

Cara, valeu o feedback ai! :-)

[]'s

Ruben disse...

Será que o Daniel ou alguém aí poderia fornecer os dados para configurar o APN para Claro 3G? Estou tendo dificuldades.

Grato

Daniel disse...

ai está:
APN: claro.com.br
user: claro
senha: claro
autenticação: PAP
tipo: default

AINDA estou com um problema: quando meu celular fica muito tempo em standby, ele parece que se desliga da rede de dados, e para conectar novamente é totalmente arbitrário. quando eu abro o navegador ou qualquer outro app que use internet, ele não conecta automaticamente.. a "solução" que descobri foi colocar em modo avião e depois voltar.. ele conecta novametne dai.. mas assim é muito precário! o que eu posso fazer??

outra coisa... raramente vejo escrito "3G" no celular, e quando aparece.. dura só alguns segundos.. normalmente é H ou E, porque isso? como faço para ele pegar mais 3G do que edge? (CLARO)

Zamana disse...

Esse lance de desconectar o WiFi e conectar de novo é a macumba que eu faço também.

Esse problema é tão comum e manjado que há vários programinhas no Market para [tentar] resolver isso. Um deles é o "WiFi Fixer": não resolve em todos os casos, mas ajuda em algumas situações.

Estou com a versão Thai 2.1 mas pretendo colocar a Canadense Telus para ver se muda alguma coisa em relação ao WiFi.

Anônimo disse...

aki estou vendo que so tem feras no assunto!!
então vai o meu problema, o meu é vivo! peguei o codigo de edsbloqueio na vivo! mais quando ponho o chip da: phone is subsidy locked.please contact service provider .only emergency calls sre allowed
ja, fiz o procedimento acima, ja dei reset esperei 4 dias com o chip de outra operadora!
alguem sabe como resolver???

Daniel disse...

Zamana, meu problema nada tem a ver com redes wifi, mas sim com redes móveis (3g e etc). quando fico muito tempo sem usar, o celular se desliga delas (aparentemente) e é totalmente arbitrário o momento que ele volta a se conectar, em outros celulares, usar um browser faria ele reconectar, mas no droid, descobri que ir para o modo avião e retornar ao normal faz ele pescar o sinal novamente, O QUE DEVERIA SER DESNECSSÁRIO, além de ser um saco.
ainda tem o outro problema de nunca pegar redes 3g propriamente ditas, mas sim E (suponho que seja edge) e H (não faço ideia o que é).

Zamana disse...

Engraçado, mas este já é um problema que eu não tenho. De qualquer modo parecem bugs relacionados.

Bom, ontem à noite instalei a versão canadense da 2.1 (Telus) e funciona na boa também. Ainda não deu para verificar se esses bugs foram corrigidos.

Quanto ao "H", dê uma olhada aqui:
http://pt.wikipedia.org/wiki/HSPA

Te'+!

ERICK THIAGO disse...

A versão 2.1 não traz o aplicativo gallery,eu achei aqui.

http://mobilerumor.blogspot.com/

e tem muito mais coisas legais.

Daniel disse...

Legal, saiu a versão 2.1 retail, mas meu Motorola phone update NUNCA encherga meu droid, não importa oque eu faça. pelo jeito vou ter que usar o RSDLite de novo, mas não faço ideia onde conseguir a imagem 2.1 brasileira retail, alguém faz?
valeu!
ou se alguém consertar meu moto update, melhor ainda hahah

Zamana disse...

Opa! Eu sei.
Aqui você encontra as imagens:
http://and-developers.com/motorola_milestone:sbf
Quando a coluna "Provider" está em branco, indica que a versão é "genérica", ou "retail" como dizem.

Te'+!

Ronald Bulbow disse...

Fala Eduardo.
Como disponibilizaram a imagem brasileira (tanto a 'retail' quanto da Vivo), baixei a imagem 'retail' e fiz a atualização, pois estava utilizando a versão 'Thai' desde então.
Até agora, aparentemente tudo normal.
Para o processo, utilizei:

- RSD Lite 4.6
- SBF Brazil - Build Number: SHLA_U2_03.05.0 (Service Version)

A mesma solução de 'root' da versão Thai funcionou para a brasileira.
Qualquer novidade, compartilho aqui no blog.
[]'s

Referência:
- SBF: http://and-developers.com/motorola_milestone:sbf


Ronald Bulbow
Motorola Milestone 2.1 'Rooted'

Daniel disse...

que bom que deu tudo certo pra ti, pois aqui deu merda.
fiquei mais de uma hora após dar o 100% e não dava o PASS para eu poder desconectar. certo momento conclui que só podia ter dado errado, fechei o programa e meu celular agora está preso na tela da motorola. pois é, não sei o que fazer.. vou levar na autorizada pra ver se tem jeito.

Eduardo Otubo disse...

@Ronald,
obrigado pela contribuição cara! Vou atualizar o post com seus detalhes!

@Daniel,
não sei o que pode ter dado de errado. mas acho que a moçada aqui pode te ajudar. Valeu pela contribuição também. :)

Zamana disse...
Este comentário foi removido pelo autor.
Zamana disse...

@Daniel,

Antes de levar na autorizada tenta seguir esse tutorial aqui. Esse negócio de parar antes do PASS é meio comum. Comigo já aconteceu 2 vezes mas nunca deu problema:

1) Desplugue o telefone e desligue-o; mantenha o RSDLite aberto;

2) Remova a bateria por cerca de 5 segundos, e coloque-a novamente;

3) Ligue e plugue novamente o celular, e espere que o RSDLite reconheça-o e termine o processo;

4) Muito provavelmente você vai se ver o RSDLite apontar Finished/PASS na tela.


Se você já saiu do RSDLite e tal, tente dar pelo menos um boot de recovery nele (Power + Câmera).